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About Exterro 

Exterro was founded with the simple vision that applying the concepts of process optimization and data science to 

how companies manage digital information and respond to litigation would drive more successful outcomes at a 

lower cost. We remain committed to this vision today. We deliver a fully integrated Data Risk Management platform 

that enables our clients to address their privacy, regulatory, compliance, digital forensics, and litigation risks more 

effectively and at lower costs. We provide software solutions that help some of the world’s largest organizations, law 

enforcement and government agencies work smarter, more efficiently, and support the Rule of Law. 

1 Processing Metrics 

The processing count and time of various evidence in FTK 8.2 SP2 version are recorded. 

 

AWS Machine Configuration: 

 

The metrics are recorded with an AWS machine with the following configuration: 

• Server Versions: Windows Server 2019 datacenter 

• Processor: Intel(R) Xeon(R) Platinum 8124M CPU @ 3.00GHz 

• System Type: 64 bit 

• RAM: 32 GB 

• Instance Type: C5.4.XLarge (16 core processor) 
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Standalone:  

• All the recommended installers are installed in a single AWS machine and the corresponding test results are 

recorded. 

 

Distributed Processing Manager:  

• Exterro FTK application is installed in a separate AWS machine. 

• The Exterro Database is hosted in a separate AWS machine. 

• Distributed Processing Manager (DPM) is installed in a separate machine. 

• 3 Distributed Processing Engines (DPEs) are installed in 3 individual AWS machines. 
 

The below mentioned metrics are recorded based with evidence in a separate shared AWS machine for FTK 8.2 SP2 

(SQL Server) which was accessed via shared path. 

Evidence Name 
Standalone  Distributed (3 DPE's) 

Processing Count & Time (HH:MM:SS) 

Sheriff Taylor 

Enumerated: 757196 

Processed: 757196 

Indexed: 267601 

Job time: 00:37:08 

Enumerated: 757196 

Processed: 757196 

Indexed: 267601 

Job time: 00:12:21 

Cox 100 GB 

Enumerated: 1635999 

Processed: 1635999 

Indexed: 1408951 

Job time: 02:30:29 

Enumerated: 1635999 

Processed: 1635999 

Indexed: 1408951 

Job time: 00:52:47 

LG E975 

Enumerated: 8674 

Processed: 8674 

Indexed: 4316 

Job time: 00:05:54 

Enumerated: 8674 

Processed: 8674 

Indexed: 4316 

Job time: 00:05:09 

Red MI Note 3 

Enumerated: 69422 

Processed: 69422 

Indexed: 40824 

Job time: 00:09:24 

Enumerated: 69422 

Processed: 69422 

Indexed: 40824 

Job time: 00:10:20 
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Evidence Name 
Standalone  Distributed (3 DPE's) 

Processing Count & Time (HH:MM:SS) 

Macmini_unlocked 

Enumerated: 358191 

Processed: 358191 

Indexed: 251790 

Job time: 00:23:54 

Enumerated: 358191 

Processed: 358191 

Indexed: 251790 

Job time: 00:08:43 

mojave2_e01_image.E01 

Enumerated: 679429 

Processed: 679429 

Indexed: 620879 

Job time: 00:56:02 

Enumerated: 679429 

Processed: 679429 

Indexed: 620879 

Job time: 00:24:02 

Mike-37 

Enumerated: 2239729 

Processed: 0 

Indexed: 0 

Job time: 01:01:44 

Enumerated: 2239729 

Processed: 0 

Indexed: 0 

Job time: 01:03:53 

Bigsur-vhd-0309-field 

Enumerated: 35310 

Processed: 0 

Indexed: 0 

Job time: 00:01:40 

Enumerated: 35310 

Processed: 0 

Indexed: 0 

Job time: 00:01:41 

Mac-Monterary-Peripheral 

Enumerated: 89187 

Processed: 0 

Indexed: 0 

Job time: 00:04:55 

Enumerated: 89187 

Processed: 0 

Indexed: 0 

Job time: 00:04:42 

Samsung S10 Lite 

Enumerated: 384230 

Processed: 384230 

Indexed: 299459 

Job time: 01:28:32 

Enumerated: 384230 

Processed: 384230 

Indexed: 299459 

Job time: 01:01:34 

Google Pixel 13 A (Android 10) 

Enumerated: 277396 

Processed: 277396 

Indexed: 225497 

Job time: 00:36:55 

Enumerated: 277396 

Processed: 277396 

Indexed: 225497 

Job time: 00:24:00 
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Evidence Name 
Standalone  Distributed (3 DPE's) 

Processing Count & Time (HH:MM:SS) 

iPhone 12 (Grayshift) 

Enumerated: 521381 

Processed: 521381 

Indexed: 452639 

Job time: 00:55:55 

Enumerated: 521381 

Processed: 521381 

Indexed: 452639 

Job time: 00:30:16 

iOS_13_4_1 

Enumerated: 377674 

Processed: 377674 

Indexed: 343415 

Job time: 00:49:34 

Enumerated: 377674 

Processed: 377674 

Indexed: 343415 

Job time: 00:33:06 

Android 13 

Enumerated: 145561 

Processed: 145561 

Indexed: 113501 

Job time: 00:30:42 

Enumerated: 145561 

Processed: 145561 

Indexed: 113501 

Job time: 00:27:59 

EnronPST_76GB 

Enumerated: 1719577 

Processed: 1719577 

Indexed: 1694542 

Job time: 02:02:02 

Enumerated: 1719577 

Processed: 1719577 

Indexed: 1694542 

Job time: 01:08:43 

Grayshift iOS-13.0 

Enumerated: 462400 

Processed: 462400 

Indexed: 441433 

Job time: 00:39:18 

Enumerated: 462400 

Processed: 462400 

Indexed: 441433 

Job time: 00:20:51 

MVS2025_Magnet_iOS 

Enumerated: 193520 

Processed: 193520 

Indexed: 172926 

Job time: 00:21:04 

Enumerated: 193520 

Processed: 193520 

Indexed: 172926 

Job time: 00:11:01 

CategoryMBOX 

Enumerated: 441711 

Processed: 441711 

Indexed: 358269 

Job time: 04:33:17 

Enumerated: 441711 

Processed: 441711 

Indexed: 358269 

Job time: 01:23:02 
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2 Standalone Performance Benchmark Metrics 

2.1 Performance Benchmark environment and configuration 
 

A series of performance tests were executed to determine the application load time response when bulk users are 

accessing the application. A maximum of 10 users were made to log in to the application simultaneously with a ramp-

up period of 3 seconds and randomly hit all the Manage pages. 

 

The load details of the database and the server is provided below: 

 

# Name of the Entity Active Count 

1 Case 2 

2 Review Page 10,834,519 

 

Server 
Instance 

type/processor 

Drive 
RAM Size 

Operating 

System Size Type R/W Speed 

Application Server & 

PostgreSQL 

Database Server 

C5.4.XLarge  

16 core processor 
4.5 TB  SSD 16,000 32 GB 

Windows Server 

2019 (64 - bit OS) 
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2.1.1 Test Bed Set-up 

 

1. The tests were performed on the below user preference settings in the application: 

• Manage Page View : Table View 

• Results per page : 100 

• Ramp-up  : 3 seconds 

 
 

2. The performance scripts of the Manage pages were taken by triggering the APIs from an AWS machine (say 

Machine 1) and hitting the other AWS machine (say Machine 2). Here, Machine 1 consisted of the Performance 

Test scripts and Machine 2 consisted of Performance Test data. 

 

2.1.2 AWS Machine Details 

 

• Server Versions : Windows Server 2019 Datacenter (64 – bit OS) 

• RAM    : 32 GB 

• Database Server : PostgreSQL 

 

Important: The metrics are recorded with database cache, partition table and index implementation. The database 

cache query is executed upon every successful upgrade and new installation. 

 

Name of the Page 
No. of users - 1 No. of users - 10 

Average Time Taken (in seconds) 

Manage Case 0.189 0.219 

Review 35.4 13.309 

Thumbnail View 1.744 1.699 
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2.2 Overview of Performance Fixes 

 

1. Implementation of Partition Table makes the DB query execution faster. 

Note: The performance of Evidence Processing is dependent on the partition table. 

 

2. Automatic execution of DB cache query upon every Upgrade or New Installation of Exterro FTK application in 

the following areas:  

• Left pane Filters 

• Review Page Loading 

• Column filters 

 

3. Scrutinizing the DB queries for 

• Applying or removing of filters on Left Pane, Column Filters 

• Automatic loading of Review page and Coding panel actions on review page. 

 

4. Modifying applicable API calls querying to be taken from: 

• Cache for counts 

• Pagination 

• Static filters 

• Left pane filters 

• Review Page Loading 

• Column filters 

 

5. New API calls for querying the counts on performing the search on the: 

• Review page 

• Evidence list operation 

• ‘ItemDataGrid’ data functions in separate threads 

• Added an index on ‘FileCategory’ and ‘EvidenceId’ 
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6. Changes in properties files to support the restriction of Payload request in the API calls which take the necessary 

responses only. 

7. Removing or modifying the default operators in the column filter for loading and applying Filter purposes. 

8. Implementation of background job to filter the results and make the UI accessible at initial loading of the data. 

9. The API calls are now modified to fetch the database cache instead of querying the database. 
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2.3 Test Scenarios 

2.3.1 Single User Performance Metrics in FTK Central 8.2 SP2 

 

The below time stamps (in seconds) are recorded for a single user with 1.5 million files and 10 million files in FTK 

Central 8.2 SP2 application (PostgreSQL database) with a ramp-up of 3 seconds: 

 

Page Navigation: 

 

Test Scenarios 
10 Million Files 1.5 Million Files 

Average Time Taken for 1 User (In Seconds) 

Login 0.13 0.195 

Manage Case List 0.189 0.219 

Review Page 35.4 13.309 

Not Viewed  12.584 0.537 

Artifacts api 5.067 2.889 

Evidence Explorer API 0.15 0.474 

Pagination Next (List View) 0.212 0.202 

Pagination Previous (List View) 0.196 0.189 

Thumbnail View 1.744 1.699 

Next Page (Thumbnail View) 0.203 0.205 

Previous Page (Thumbnail View) 0.195 0.195 

Jump to any Page (Thumbnail View) 0.253 0.239 
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Searches: 

 

Test Scenarios 
10 Million Files 1.5 Million Files 

Average Time Taken for 1 User (In Seconds) 

Basic Search > Boolean 2.314 0.387 

Basic Search > Wildcard 1.826 0.229 

Basic Search > All 3 combination 2.135 0.245 

Adv. Search > Boolean 4.772 0.215 

Adv. Search > Wildcard 2.67 0.236 

Adv. Search > All 3 combination 2.781 0.213 

Adv. Search > All 3 combination > Any include Related docs 3.248 0.23 

Adv. Search > All 3 combination > Any More Options 2.76 0.223 

Search query in stemming with the complex queries 3.2 0.214 

Remove Text Search 0.386 0.402 

Remove Adv Text Search (100 docs) 0.69 0.55 
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Quick Filters: 

 

Test Scenarios 
10 Million Files  1.5 Million Files 

Average Time Taken for 1 User (In Seconds) 

Quick Filter > Labeled Fields > Apply 0.328 0.227 

Quick filter > Labeled Fields > Remove 0.218 0.198 

Quick Filter > Checked Files > Apply 0.148 0.112 

Quick Filter > Checked Files > Remove 0.2 0.306 

Quick Filter > Toggle Bookmark or Reports Filter > Apply 0.155 0.211 

Quick Filter > Toggle Bookmark or Reports Filter > Remove 0.207 0.212 

Quick Filter > Ignorable > Apply 0.149 0.12 

Quick Filter > Ignorable > Remove 0.206 0.194 

Quick Filter> Internet favorites > Apply 0.219 0.116 

Quick Filter > Internet favorites > Remove 0.205 0.193 

Quick Filter > Privileged > Apply 0.213 0.118 

Quick Filter > Privileged > Remove 0.206 0.21 

Quick Filter > Remove Duplicates > Apply 0.212 0.226 

Quick Filter > Remove Duplicates > Remove 0.198 0.225 

Quick Filter > Deleted Files > Apply 0.294 0.122 

Quick Filter > Deleted Files > Remove 0.205 0.303 

Quick Filter > Carved Files> Apply 0.123 0.124 

Quick Filter > Carved Files > Remove 0.203 0.429 

Quick Filter > Encrypted Files > Apply 0.312 0.155 

Quick Filter > Encrypted Files > Remove 0.207 0.202 

Quick Filter > From Recycle Bin > Apply 0.206 0.159 

Quick Filter > From Recycle Bin > Remove 0.208 0.206 

Quick Filter > OCRed Files > Apply 0.126 0.116 

Quick Filter > OCRed Files > Remove 0.204 0.3 

Quick Filter > Bad Extension > Apply 0.215 0.195 
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Test Scenarios 
10 Million Files  1.5 Million Files 

Average Time Taken for 1 User (In Seconds) 

Quick Filter > Bad Extension > Remove 0.301 0.194 

Quick Filter > Hidden Files > Apply 0.214 0.122 

Quick Filter > Hidden Files > Remove 0.197 0.197 

Quick Filter > Email Attachment > Apply 0.228 0.171 

Quick Filter > Email Attachment > Remove 0.201 0.194 

Quick Filter > Geo Location> Apply 0.221 0.152 

Quick Filter > Geo Location > Remove 0.204 0.198 

Quick Filter > eDiscovery Refinement > Apply 0.252 0.331 

Quick Filter > eDiscovery Refinement > Remove 0.348 0.233 

Quick Filter > Notes and Bookmarks > Apply - - 

Quick Filter > Notes and Bookmarks > Remove - - 

Quick Filter > Containers > Apply 0.243 0.418 

Quick Filter > Containers > Remove 0.226 0.32 

 

  

http://www.exterro.com/


 

 

 

 

15 

FTK SUITE 8.2 SP2 - BENCHMARK METRICS 

© Exterro, Inc. All rights reserved.         www.exterro.com 

 

Common Filters: 

 

Test Scenarios 
10 Million Files 1.5 Million Files 

Average Time Taken for 1 User (In Seconds) 

CommonFilter > Bookmarks > Load 5.389 0.075 

CommonFilter > Bookmarks > Apply 0.18 0.152 

CommonFilter > Bookmarks > Remove 0.313 0.187 

CommonFilter > CerebrusSTG1 > Load  0.204 0.154 

CommonFilter > Custodians > Load 0.038 0.035 

CommonFilter > CustomField > Load 0.053 0.039 

CommonFilter > DateAccessed > Load 0.052 0.043 

CommonFilter > DateAccessed > 1 > Apply 0.255 0.199 

CommonFilter > DateAccessed > 1 > Remove 0.197 0.191 

CommonFilter > DateCreated > Load 0.063 0.048 

CommonFilter > DateCreated > 1 > Apply 1.428 0.175 

CommonFilter > DateCreated > 1 > Remove> 0.197 0.193 

CommonFilter > DateModified > 1 > Load 0.063 0.042 

CommonFilter > DateModified > 1 > Apply 1.266 0.43 

CommonFilter > DateModified > 1 > Remove 0.215 0.194 

CommonFilter > DocumentContent > ClusterTopic > Load 0.084 0.073 

CommonFilter > DocumentContent > ClusterTopic > Apply 0.126 0.118 

CommonFilter > DocumentContent > EmailAddress > Load 0.036 0.036 

CommonFilter > DocumentContent > CCN > Load 0.037 0.036 

CommonFilter > DocumentContent > PHNO > Load 0.04 0.035 

CommonFilter > DocumentContent > SSN > Load 0.039 0.036 

CommonFilter > Viewed > Load 12.459 0.251 

CommonFilter > Viewed > NV > Apply 0.164 0.145 

CommonFilter > Viewed > NV > Remove 0.205 0.296 

CommonFilter > Viewed > V > Apply 0.161 0.144 
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Test Scenarios 
10 Million Files 1.5 Million Files 

Average Time Taken for 1 User (In Seconds) 

CommonFilter > Viewed > V > Remove 0.206 0.194 

CommonFilter > Status > Load 18.058 0.048 

CommonFilter > Status > BadExt > Apply 0.214 0.196 

CommonFilter > Status > BadExt > Remove 0.205 0.189 

CommonFilter > Status > DelFiles > Apply 0.311 - 

CommonFilter > Status > DelFiles > Remove  0.203 - 

CommonFilter > Status > EmailAttachment > Apply 0.208 0.143 

CommonFilter > Status > EmailAttachment > Remove 0.209 0.191 

CommonFilter > Status > EmailRelatedItem > Apply 0.329 0.407 

CommonFilter > Status > EmailRelatedItem > Remove 0.209 0.195 

CommonFilter > Status > EmailReply > Apply 0.208 0.136 

CommonFilter > Status > EmailReply > Remove 0.199 0.19 

CommonFilter > Status > EncryptedFiles > Apply 0.212 0.145 

CommonFilter >Status > EncryptedFiles > Remove 0.205 0.193 

CommonFilter > Status > Recyclebin > Apply 0.217 0.152 

CommonFilter > Status > Recyclebin > Remove 0.2 0.192 

CommonFilter > Size > Load 5.776 0.048 

CommonFilter > Size > Gigantic > Apply 0.218 0.158 

CommonFilter > Size > Gigantic > Remove 0.324 0.19 

CommonFilter >Size > Huge > Apply 0.208 0.296 

CommonFilter > Size> Huge > Remove 0.199 0.192 

CommonFilter > Size > Large > Apply 0.214 0.196 

CommonFilter > Size > Large > Remove 0.34 0.192 

CommonFilter > Size > Medium > Apply 0.217 0.37 

CommonFilter > Size > Medium > Remove 0.203 0.196 

CommonFilter > Size > Small > Apply 0.209 0.297 

CommonFilter > Size > Small > Remove 0.315 0.191 
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Test Scenarios 
10 Million Files 1.5 Million Files 

Average Time Taken for 1 User (In Seconds) 

CommonFilter > Size > Tiny > Apply 0.316 0.201 

CommonFilter > Size > Tiny > Remove 0.204 0.197 

CommonFilter > Size > Empty > Apply 0.201 0.191 

CommonFilter > Size > Empty > Remove 0.197 0.285 

CommonFilter > Language > Load 0.094 0.08 

CommonFilter > ObjectTypes > Load 1.986 0.043 

CommonFilter > ObjectTypes > CaseOrganizer > Apply 0.215 - 

CommonFilter > ObjectTypes > CaseOrganizer > Remove 0.41 - 

CommonFilter > ObjectTypes > Files & Email > Apply 0.467 0.19 

CommonFilter > ObjectTypes > Files & Email > Remove 0.39 0.191 

CommonFilter >ProductionSets > Load 13.566 0.048 

CommonFilter > ProductionSets > Apply 0.321 0.2 

CommonFilter > ProductionSets > Remove  0.204 0.186 

CommonFilter > Labels > Load 0.072 0.076 

CommonFilter > Labels > 1 > Apply 0.305 0.143 

CommonFilter > Labels > 1 > Remove 0.2 0.259 

CommonFilter > EmailDate > Load - 0.051 

CommonFilter > EmailDate > Received > Apply - 0.195 

CommonFilter > EmailDate > Received > Remove 0.089 0.201 

CommonFilter > EmailDate > Sent > Apply 0.06 0.264 

CommonFilter > EmailDate > Sent > Remove 0.066 0.205 

CommonFilter > Extension > Load 0.06 0.297 

CommonFilter > Extension > 1 > Apply 0.063 0.292 

CommonFilter > Extension > 2 > Remove 24.136 0.198 

CommonFilter > Labels > 2 > Apply 0.296 - 

CommonFilter > Labels > 2 > Remove 0.342 - 

CommonFilter > Issues > Load 0.299 0.08 
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Test Scenarios 
10 Million Files 1.5 Million Files 

Average Time Taken for 1 User (In Seconds) 

CommonFilter > KFF > kff vendors > Load 0.205 0.097 

CommonFilter > KFF> kff groups > Load 1.341 0.057 

CommonFilter > KFF > kff status > Load 0.595 0.056 

CommonFilter > KFF > kff sets > Load 0.203 0.059 
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Column Filters: 

 

Test Scenarios 
10 Million Files  1.5 Million Files  

Average Time Taken for 1 User (In Seconds) 

ColumnFilters>ObjectName>Apply 1.898 0.209 

ColumnFilters>ObjectName>Remove 0.242 0.227 

ColumnFilters>ObjectID>Apply 0.14 0.128 

ColumnFilters>ObjectID>Remove 0.236 0.243 

ColumnFilters>CreateDate>Load 19.02 2.302 

ColumnFilters>CreateDate>Apply 0.17 0.157 

ColumnFilters>CreateDate>Remove 0.245 0.33 

ColumnFilters>LastModifiedDate>Load 24.222 2.639 

ColumnFilters>LastModifiedDate>Apply 0.154 0.179 

ColumnFilters>LastModifiedDate>Remove 0.246 0.229 

ColumnFilters>FileType>Load 9.199 0.764 

ColumnFilters>FileType>1>Apply 0.208 0.113 

ColumnFilters>FileType>Remove 0.227 0.228 

ColumnFilters>FileExt>Load 2.342 0.348 

ColumnFilters>FileExt>Apply> 0.221 0.201 

ColumnFilters>FileExt>Remove 0.239 0.23 

ColumnFilters>Path>Apply 0.735 0.413 

ColumnFilters>Path>Remove 0.239 0.53 

ColumnFilters>MD5>Apply 0.148 0.14 

ColumnFilters>MD5>Remove 0.222 0.225 
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Filter Artifacts: 

 

Test Scenarios 
10 Million Files  1.5 Million Files 

Average Time Taken for 1 User (In Seconds) 

Artifacts>Highlight>Enabled 2.102 2.206 

Artifacts>Highlight>Excluded 0.301 0.268 

Artifacts>Highlight>Removed 0.244 0.179 

Artifacts>Multimedia>Enabled 0.319 0.403 

Artifacts>Multimedia>Excluded 0.343 0.322 

Artifacts>Multimedia>Removed 2.09 0.261 

Artifacts>Mobile>Enabled 0.193 - 

Artifacts>Mobile>Excluded 0.239 - 

Artifacts>Mobile>Removed 1.95 - 

Artifacts>Docs>Enabled 2.652 2.55 

Artifacts>Docs>Excluded 0.584 0.684 

Artifacts>Docs>Removed 0.237 0.357 

Artifacts>Emails>Enabled 2.207 2.502 

Artifacts>Emails>Excluded 0.317 0.352 

Artifacts>Emails>Removed 0.237 0.358 

Artifacts>OSFile>Enabled 2.435 0.303 

Artifacts>OSFile>Excluded 0.341 0.346 

Artifacts>OSFile>Removed 0.265 0.256 

Artifacts>DB>Enabled 0.347 0.326 

Artifacts>DB>Excluded 0.36 0.324 

Artifacts>DB>Removed 0.256 0.231 

Artifacts>GeoLocation>City>Load 0.344 0.083 

Artifacts>GeoLocation>City>Enable 1.065 0.384 

Artifacts>GeoLocation>City>Excluded 0.254 0.384 

Artifacts>GeoLocation>City>Removed 0.3 0.224 

Artifacts>Others>Enabled 0.406 0.263 
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Test Scenarios 
10 Million Files  1.5 Million Files 

Average Time Taken for 1 User (In Seconds) 

Artifacts>Others>Excluded 0.347 0.496 

Artifacts>Others>Removed 0.293 0.29 

Artifacts>Internet Browser>Enabled 0.417 2.034 

Artifacts> Internet Browser >Excluded 0.411 0.305 

Artifacts> Internet Browser >Removed 0.236 0.349 

Artifacts>Chatapps>Enabled 0.426 - 

Artifacts>Chatapps>Excluded 0.295 - 

Artifacts>Chatapps>Removed 0.228 - 

Artifacts>System Summary>Enabled 0.727 - 

Artifacts>System Summary>Excluded 0.835 - 

Artifacts>System Summary>Removed 0.355 - 

 

Evidence: 

 

Test Scenarios 
10 Million Files 1.5 Million Files  

Average Time Taken for 1 User (In Seconds) 

Evidence 1 > Apply 5.312 0.314 

Evidence 1 > Exclude 0.198 0.455 

Evidence 1 > Remove 0.266 0.209 
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Combination Filters 1: 

Common Filters + Artifacts + Quick Filters 

 

Test Scenarios 
10 Million Files 1.5 Million Files 

Average Time taken for 1 User (In Seconds) 

Common filter : Object types > Files and Emails 0.436 0.466 

Common filter + Artifacts >Chat application 0.211 
 

Common filter + Artifacts >Chat application , Documents 3.665 2.446 

Common filter + Artifacts >Chat application , Documents , 

Internet & Browsers 0.525 0.492 

Common filter + Artifacts >Chat application , Documents , 

Internet & Browsers, Emails 0.72 0.424 

Common filter + Artifacts + Quick Filter applied on>Remove 

Containers 0.787 0.318 

Common filter + Artifacts + Quick Filter applied on>Remove 

Containers, Remove Notes and Bookmark - - 

Common filter + Artifacts + Quick Filter applied on>Remove 

Containers, Remove Notes and Bookmark, Remove Duplicates 

[Combination 1 Result] [Quick Filters, Common Filters, Artifacts] 0.718 0.265 

 

Combination Filters 1 Exclusion 

 

Test Scenarios 
10 Million Files 1.5 Million Files 

Average Time taken for 1 User (In Seconds) 

Combination 1 + Document from Artifact 5.078 2.398 
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Combination Filters 2: 

Common Filters + Artifacts + Evidence 

 

Test Scenarios 
10 Million Files 1.5 Million Files 

Average Time taken for 1 User (In Seconds) 

Common Filter>Size>Tiny 0.245 0.241 

Common Filter>Size>Tiny, Gigantic 0.24 0.254 

Common Filter>Size>Tiny, Gigantic, Small 0.341 0.256 

Common Filter>Size>Tiny, Gigantic, Small, Empty 0.443 0.428 

Common Filter + Artifacts filter> Document 0.433 0.447 

Common Filter + Artifacts filter> Document, Email 0.585 - 

Common Filter + Artifacts filter + Evidence 

Explorer>Evidence 1 0.594 - 

Common Filter + Artifacts filter + Evidence 

Explorer>Evidence 1, Evidence 2 0.62 - 

Common Filter + Artifacts filter + Evidence 

Explorer>Evidence 1, Evidence 2,Evidence 3 0.605 - 

Common Filter + Artifacts filter + Evidence 

Explorer>Evidence 1, Evidence 2,Evidence 3, Evidence 

4 0.245 0.241 
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Combination Filters 2 Exclusion 

 

Test Scenarios 
10 Million Files 1.5 Million Files 

Average Time taken for 1 User (In Seconds) 

Combination 2 Filters + Common Filter>size>Small 1.103 - 

Combination 2 Filters + Common Filter>size>Small, 

Empty 1.066 - 

Combination 2 Filters + Evidence explorer>Evidence 1 6.196 - 

Combination 2 Filters + Evidence explorer>Evidence 1, 

Evidence 2 4.477 - 

 

Combination Filters 3:  

Evidence Dropdown + Evidence Explorer 

 

Test Scenarios 
10 Million Files 1.5 Million Files 

Average Time taken for 1 User (In Seconds) 

Evidence dropdown>Select Evidence 1 1.835 - 

Evidence dropdown>Select Evidence 1, Evidence 2 2 - 

Evidence dropdown>Select Evidence 1, Evidence 2, 

Evidence 3 2.088 - 

Evidence dropdown>Select Evidence 1, Evidence 2, 

Evidence 3, Evidence 4 0.453 - 

Evidence dropdown>Select Evidence 1, Evidence 2, 

Evidence 3, Evidence 4, Evidence 5 0.443 - 

Evidence dropdown>Select Evidence 1, Evidence 2, 

Evidence 3, Evidence 4, Evidence 5, Evidence 6 0.452 - 

Evidence dropdown>Select Evidence 1, Evidence 2, 

Evidence 3, Evidence 4, Evidence 5, Evidence 6, 

Evidence 7 0.374 - 
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Test Scenarios 
10 Million Files 1.5 Million Files 

Average Time taken for 1 User (In Seconds) 

Evidence dropdown>Select Evidence 1, Evidence 2, 

Evidence 3, Evidence 4, Evidence 5, Evidence 6, 

Evidence 7, Evidence 8 0.359 - 

Evidence dropdown + Evidence Explorer>Select 

Evidence 1 2.035 - 

Evidence dropdown + Evidence Explorer>Select 

Evidence 1, Evidence 2 2.123 - 

Evidence dropdown + Evidence Explorer>Select 

Evidence 1, Evidence 2, Evidence 3 2.236 - 

Evidence dropdown + Evidence Explorer>Select 

Evidence 1, Evidence 2, Evidence 3, Evidence 4 2.278 - 

Evidence dropdown + Evidence Explorer>Select 

Evidence 1, Evidence 2, Evidence 3, Evidence 4, 

Evidence 5 0.608 - 
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Combination Filters 3 Exclusion 

 

Test Scenarios 
10 Million Files 1.5 Million Files 

Average Time taken for 1 User (In Seconds) 

Evidence dropdown + Evidence Explorer>Exclude Evidence 1 0.583 - 

Evidence dropdown + Evidence Explorer>Exclude Evidence 1, 

Evidence 2 0.545 - 

Evidence dropdown + Evidence Explorer>Exclude Evidence 1, 

Evidence 2, Evidence 3 6.451 - 

 

Combinational Filters 3 + Combination Filters 4:  

Quick Filters + Common Filters + Artifacts 

 

Test Scenarios 
10 Million Files 1.5 Million Files 

Average Time taken for 1 User (In Seconds) 

Artifacts>Document 6.472 - 

Artifacts>Document, Email 6.496 - 

Artifacts>Document, Email, Mobile 6.407 - 

Artifacts + Common Filter> Size 0.742 - 

Artifacts + Common Filter + Quick filter>Remove Duplicates 12.224 - 

Artifacts + Common Filter + Quick filter>Remove Duplicates, 

Remove Containers [Combination 3 Result] [Evidence 

Dropdown, Evidence Explorer, Artifacts, Quick filter, Common 

filter] 7.751 - 
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Combinational Filters 3 + Combination Filters 4 Exclusion 

 

Test Scenarios 
10 Million Files 1.5 Million Files 

Average Time taken for 1 User (In Seconds) 

Artifacts>Document 7.665 - 

Evidence Explorer>Exclude Evidence 1 7.172 - 

Evidence Explorer>Exclude Evidence 1, Evidence 2 5.892 - 

Evidence Explorer>Exclude Evidence 1, Evidence 2, Evidence 3 6.141 - 

 

List View - Column Template List 

 

Test Scenarios 
10 Million Files 1.5 Million Files 

Average Time taken for 1 User (In Seconds) 

Column Template List > Documents - - 

Column Template List > Airdrop background activity & 

discoverability 2.168 2.191 

Column Template List > Apple Maps 2.217 2.132 

Column Template List > Applications 2.269 2.142 

Column Template List > Bluetooth network 2.235 2.076 

Column Template List > Calendar 2.271 2.038 

Column Template List > Common 2.179 2.083 

Column Template List > Device information 2.432 2.087 

Column Template List > Email 0.255 2.269 

Column Template List > Health Data 2.158 2.113 

Column Template List > Installed App 2.368 2.247 

Column Template List > InteractionC Information 2.164 2.064 

Column Template List > Internet 2.276 2.232 

Column Template List > Keychain Information 2.183 1.928 

Column Template List > KnowledgeC Information 2.146 2.196 
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Test Scenarios 
10 Million Files 1.5 Million Files 

Average Time taken for 1 User (In Seconds) 

Column Template List > Layout 2.331 2.142 

Column Template List > Location 2.076 2.265 

Column Template List > LocationD Information 2.363 2.13 

Column Template List > MMS 2.312 2.082 

Column Template List > Media 2.29 2.153 

Column Template List > Memory Analysis 2.156 2.136 

Column Template List > Mobile 2.342 1.965 

Column Template List > Notes 2.158 2.184 

Column Template List > Password 2.192 2.188 

Column Template List > Report 2.21 2.056 

Column Template List > RoutineD cached locations data 2.324 2.149 

Column Template List > Search 2.262 1.943 

Column Template List > Software Inventory 2.242 2.249 

Column Template List > Summary Information 2.121 2.227 

Column Template List > Timeline 0.282 0.423 

Column Template List > Volatile 2.311 2.14 

Column Template List > WebHistory 2.053 2.214 

Column Template List > Wireless Network 2.372 2.151 
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Thumbnail View - Sort By 

 

Test Scenarios 
10 Million Files 1.5 Million Files 

Average Time taken for 1 User (In Seconds) 

Sort by > Name (ASC) 1.296 0.245 

Sort by > Created Date (ASC) 2.316 0.401 

Sort by > Last Modified Date (ASC) 2.359 0.399 

Sort by > Path (ASC) 1.403 0.191 

Sort by > Logical Size (ASC) 5.363 0.727 

Sort by > Extension (ASC) 1.273 0.194 

Sort by > Duration (ASC) 1.324 0.188 

Sort by > Exif Image Make (ASC) 1.915 0.223 

Sort by > Exif Image Model (ASC) 1.25 0.326 

Sort by > Stacks (ASC) 17.127 0.164 

Sort by > Location City (ASC) 1.301 0.019 

Sort by > Location Country (ASC) 1.241 0.307 

Sort by > Name (DESC) 1.239 0.218 

Sort by > Created Date (DESC) 2.324 0.401 

Sort by > Last Modified Date (DESC) 2.28 0.398 

Sort by > Path (DESC) 2.963 0.325 

Sort by > Logical Size (DESC) 1.281 0.252 

Sort by > Extension (DESC) 1.369 0.267 

Sort by > Duration (DESC) 1.257 0.184 

Sort by > Exif Image Make (DESC) 1.334 0.218 

Sort by > Exif Image Model (DESC) 1.336 0.223 

Sort by > Stacks (DESC) 5.262 0.226 

Sort by > Location City (DESC) 1.275 0.22 

Sort by > Location Country (DESC) 1.315 0.219 
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Thumbnail View - Group By 

 

Test Scenarios 
10 Million Files 1.5 Million Files 

Average Time taken for 1 User (In Seconds) 

Group by > Name 1.068 0.163 

Group by > Created Date 2.05 0.616 

Group by > Last Modified Date 1.938 0.55 

Group by > Duration 0.402 0.21 

Group by > Extension 0.744 0.218 

Group by > Logical Size 0.243 0.165 

Group by > Exif Image Make 1.214 0.253 

Group by > Exif Image Model 1.855 0.274 

Group by > Stacks 4.79 0.306 

Group by > Location City 1.801 0.243 

Group by > Location Country 1.791 0.281 
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2.3.2 Multiuser Performance Metrics in FTK Central 8.2 SP2 

 

The below time stamps (in seconds) are recorded as a comparison between 1 user and 10 users with 10 million files 

in FTK Central 8.2 SP2 application (PostgreSQL database) where the ramp-up period is 3 seconds. 

 

Manage Pages: 

 

Test Scenarios 
1 User 10 Users 

Average Time to process 10 million files (In Seconds) 

Login   

Manage Case List 0.189 0.567 

Review Page 0.99 28.925 

Not Viewed  12.584 5.44 

Artifacts API 5.067 9.238 

Evidence Explorer API 0.15 0.46 

Pagination Next (List View) 0.212 0.521 

Pagination Previous (List View) 0.196 0.464 

Thumbnail View 1.744 3.899 

Next Page (Thumbnail View) 0.203 0.662 

Previous Page (Thumbnail View) 0.195 0.68 

Jump to any Page (Thumbnail View) 0.253 0.733 
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Searches: 

 

Test Scenarios 
1 User 10 Users 

Average Time to process 10 million files (In Seconds) 

Basic Search > Boolean 2.314 2.59 

Basic Search > Wildcard 1.826 2.339 

Basic Search > All 3 combination 2.135 2.445 

Adv. Search > Boolean 4.772 4.412 

Adv. Search > wildcard 2.67 4.478 

Adv. Search > All 3 combination 2.781 4.348 

Adv. Search > All 3 combination > Any include Related 

docs 3.248 4.42 

Adv. Search > All 3 combination > Any More Options 2.76 3.656 

Search query in stemming with the complex queries 3.2 4.478 

Remove Text Search 0.296 3.257 

Remove Adv Text Search (100 docs) 0.69 3.672 
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Quick Filters: 

 

Test Scenarios 
1 User 10 Users 

Average Time to process 10 million files (In Seconds) 

Quick filter>labeled fields>Apply 0.328 1.009 

Quick filter>labeled fields>Remove 0.218 0.705 

Quick Filter>checked files>Apply 0.148 0.645 

Quick Filter>checked files>Remove 0.2 0.603 

Quick Filter>toggle bookmark or reports filter>apply 0.155 0.381 

Quick Filter>toggle bookmark or reports 

filter>Remove 0.207 0.396 

Quick Filter>ignorable>apply 0.149 0.311 

Quick Filter>ignorable>Remove 0.206 0.445 

Quick Filter>internet favorites>apply 0.219 0.403 

Quick Filter>internet favorites>Remove 0.205 0.42 

Quick Filter>privileged>apply 0.213 0.443 

Quick Filter>privileged>Remove 0.206 0.547 

Quick Filter>remove duplicates>apply 0.212 0.421 

Quick Filter>remove duplicates>Remove 0.198 0.382 

Quick Filter>deleted files>apply 0.294 0.496 

Quick Filter>deleted files>Remove 0.205 0.429 

Quick Filter>carved files>apply 0.123 0.293 

Quick Filter>carved files>Remove 0.203 0.336 

Quick Filter>encrypted files>apply 0.312 0.336 

Quick Filter>encrypted files>Remove 0.207 0.372 

Quick Filter>from recycle bin>apply 0.206 0.33 

Quick Filter>from recycle bin>Remove 0.208 0.311 

Quick Filter>OCRed files>apply 0.126 0.202 

Quick Filter>OCRed files>Remove 0.204 0.299 
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Test Scenarios 
1 User 10 Users 

Average Time to process 10 million files (In Seconds) 

Quick Filter>bad extension>apply 0.215 0.329 

Quick Filter>bad extension>Remove 0.301 0.33 

Quick Filter>hidden files>apply 0.214 0.346 

Quick Filter>hidden files>Remove 0.197 0.452 

Quick Filter>email attachment>apply 0.228 0.538 

Quick Filter>email attachment>Remove 0.201 0.487 

Quick Filter>geo location>apply 0.221 0.487 

Quick Filter>geo location>Remove 0.204 0.573 

Quick Filter>eDiscovery refinement>apply 0.252 0.496 

Quick Filter>eDiscovery refinement>Remove 0.348 0.461 

Quick Filter>notes and bookmarks>apply  - 

Quick Filter>notes and bookmarks>Remove  - 

Quick Filter>containers>apply 0.243 0.48 

Quick Filter>containers>Remove 0.226 0.559 
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Common Filters: 

 

Test Scenarios 
1 User 10 Users 

Average Time taken for 1 User (In Seconds) 

CommonFilter > Bookmarks > Load 5.389 14.178 

CommonFilter > Bookmarks > Apply 0.18 0.593 

CommonFilter > Bookmarks > Remove 0.313 0.499 

CommonFilter > CerebrusSTG1 > Load 0.204 0.424 

CommonFilter > Custodians > Load 0.038 0.072 

CommonFilter > CustomField > Load 0.053 0.089 

CommonFilter > DateAccessed > Load 0.052 0.078 

CommonFilter > DateAccessed > 1 > Apply 0.255 0.39 

CommonFilter > DateAccessed > 1 > Remove 0.197 0.398 

CommonFilter > DateCreated > Load 0.063 0.092 

CommonFilter > DateCreated > 1 > Apply 1.428 2.29 

CommonFilter > DateCreated > 1 > Remove 0.197 0.356 

CommonFilter > DateModified > 1 > Load 0.063 0.081 

CommonFilter > DateModified > 1 > Apply 1.266 2.107 

CommonFilter > DateModified > 1 > Remove 0.215 0.306 

CommonFilter > DocumentContent > ClusterTopic > Load 0.084 0.174 

CommonFilter > DocumentContent > ClusterTopic > Apply 0.126 0.203 

CommonFilter > DocumentContent > EmailAddress > Load 0.036 0.056 

CommonFilter > DocumentContent > CCN > Load 0.037 0.061 

CommonFilter > DocumentContent > PHNO > Load 0.04 0.061 

CommonFilter > DocumentContent > SSN > Load 0.039 0.052 

CommonFilter > Viewed > Load 12.459 40.562 

CommonFilter > Viewed > NV > Apply 0.164 0.3 

CommonFilter > Viewed > NV > Remove 0.205 0.354 

CommonFilter > Viewed > V > Apply 0.161 0.273 
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Test Scenarios 
1 User 10 Users 

Average Time taken for 1 User (In Seconds) 

CommonFilter > Viewed > V > Remove 0.206 0.372 

CommonFilter > Status > Load 18.058 35.92 

CommonFilter > Status > BadExt > Apply 0.214 0.357 

CommonFilter > Status > BadExt > Remove 0.205 0.326 

CommonFilter > Status > DelFiles > Apply 0.311 0.496 

CommonFilter > Status > DelFiles > Remove 0.203 0.353 

CommonFilter > Status > EmailAttachment > Apply 0.208 0.36 

CommonFilter > Status > EmailAttachment > Remove 0.209 0.304 

CommonFilter > Status > EmailRelatedItem > Apply 0.329 0.329 

CommonFilter > Status > EmailRelatedItem > Remove 0.209 0.321 

CommonFilter > Status > EmailReply > Apply 0.208 0.311 

CommonFilter > Status > EmailReply > Remove 0.199 0.339 

CommonFilter > Status > EncryptedFiles > Apply 0.212 0.311 

CommonFilter > Status > EncryptedFiles > Remove 0.205 0.304 

CommonFilter > Status > Recyclebin > Apply 0.217 0.361 

CommonFilter > Status > Recyclebin > Remove 0.2 0.306 

CommonFilter > Size > Load 5.776 10.21 

CommonFilter > Size > Gigantic > Apply 0.218 0.334 

CommonFilter > Size > Gigantic > Remove 0.324 0.31 

CommonFilter > Size > Huge > Apply 0.208 0.385 

CommonFilter > Size > Huge > Remove 0.199 0.301 

CommonFilter > Size > Large > Apply 0.214 0.305 

CommonFilter > Size > Large > Remove 0.34 0.34 

CommonFilter > Size > Medium > Apply 0.217 0.306 

CommonFilter > Size > Medium > Remove 0.203 0.331 

CommonFilter > Size > Small > Apply 0.209 0.325 

CommonFilter > Size > Small > Remove 0.315 0.362 
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Test Scenarios 
1 User 10 Users 

Average Time taken for 1 User (In Seconds) 

CommonFilter>Size>Tiny>Apply> 0.316 0.331 

CommonFilter>Size>Tiny>Remove> 0.204 0.341 

CommonFilter>Size>Empty>Apply> 0.201 0.444 

CommonFilter>Size>Empty>Remove> 0.197 0.321 

CommonFilter>Language>Load> 0.094 0.352 

CommonFilter>ObjectTypes>Load> 1.986 6.657 

CommonFilter>ObjectTypes>CaseOrganizer>Apply> 0.215 0.355 

CommonFilter>ObjectTypes>CaseOrganizer>Remove> 0.41 0.587 

CommonFilter>ObjectTypes>FilesEmial>Apply> 0.467 4.466 

CommonFilter>ObjectTypes>FilesEmial>Remove> 0.39 4.808 

CommonFilter>ProductionSets>Load> 13.566 23.922 

CommonFilter>ProductionSets>Apply> 0.321 5.903 

CommonFilter>ProductionSets>Remove> 0.204 6.342 

CommonFilter>Labels>Load> 0.072 0.167 

CommonFilter>Labels>1>Apply> 0.305 3.378 

CommonFilter>Labels>1>Remove> 0.2 3.291 

CommonFilter>Labels>2>Apply>  - 

CommonFilter>Labels>2>Remove>  - 

CommonFilter>Issues>Load> 0.089 0.161 

CommonFilter>KFF>kffvendors>Load> 0.06 0.149 

CommonFilter>KFF>kffgroups>Load> 0.066 0.213 

CommonFilter>KFF>kffstatus>Load> 0.06 0.122 

CommonFilter>KFF>kffsets>Load> 0.063 0.115 

CommonFilter>EmailDate>Load> 24.136 56.68 

CommonFilter>EmailDate>Received>Apply> 0.296 0.651 

CommonFilter>EmailDate>Received>Remove> 0.342 0.331 

CommonFilter>EmailDate>Sent>Apply> 0.299 0.539 
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Test Scenarios 
1 User 10 Users 

Average Time taken for 1 User (In Seconds) 

CommonFilter>EmailDate>Sent>Remove> 0.205 0.332 

CommonFilter>Extension>Load> 1.341 2.305 

CommonFilter>Extension>1>Apply> 0.595 0.882 

CommonFilter>Extension>2>Remove> 0.203 0.763 

 

Column Filters: 
 

Test Scenarios 
1 User 10 Users 

Average Time to process 10 million files (In Seconds) 

ColumnFilters>ObjectName>Apply> 1.898 13.143 

ColumnFilters>ObjectName>Remove> 0.242 0.544 

ColumnFilters>ObjectID>Apply> 0.14 0.261 

ColumnFilters>ObjectID>Remove> 0.236 0.391 

ColumnFilters>CreateDate>Load> 19.02 22.456 

ColumnFilters>CreateDate>Apply 0.17 0.319 

ColumnFilters>CreateDate>Remove> 0.245 0.319 

ColumnFilters>LastModifiedDate>Load> 24.222 32.843 

ColumnFilters>LastModifiedDate>Apply> 0.154 0.244 

ColumnFilters>LastModifiedDate>Remove> 0.246 0.341 

ColumnFilters>FileType>Load> 9.199 12.674 

ColumnFilters>FileType>1>Apply> 0.208 0.307 

ColumnFilters>FileType>Remove> 0.227 0.303 

ColumnFilters>FileExt>Load> 2.342 4.225 

ColumnFilters>FileExt>Apply> 0.221 0.756 

ColumnFilters>FileExt>Remove> 0.239 0.285 

ColumnFilters>Path>Apply> 0.735 0.392 

ColumnFilters>Path>Remove> 0.236 0.276 

ColumnFilters>MD5>Apply> 0.148 0.151 
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Test Scenarios 
1 User 10 Users 

Average Time to process 10 million files (In Seconds) 

ColumnFilters>MD5>Remove> 0.222 0.303 

 

Filter Artifacts: 

 

Test Scenarios 
1 User 10 Users 

Average Time taken for 1 User (In Seconds) 

Artifacts>Highlight>Enabled 2.102 9.786 

Artifacts>Highlight>Excluded 0.264 9.841 

Artifacts>Highlight>Removed 0.229 8.741 

Artifacts>Multimedia>Enabled 0.289 9.344 

Artifacts>Multimedia>Excluded 0.343 9.057 

Artifacts>Multimedia>Removed 0.26 7.479 

Artifacts>Mobile>Enabled 0.193 7.538 

Artifacts>Mobile>Excluded 0.239 7.391 

Artifacts>Mobile>Removed 1.95 7.559 

Artifacts>Chatapps>Enabled 0.174 7.858 

Artifacts>Chatapps>Excluded 0.345 9.128 

Artifacts>Chatapps>Removed 0.24 8.317 

Artifacts>Docs>Enabled 2.207 8.407 

Artifacts>Docs>Excluded 0.566 8.563 

Artifacts>Docs>Removed 0.337 6.215 

Artifacts>Emails>Enabled 2.435 7.136 

Artifacts>Emails>Excluded 0.309 8.054 

Artifacts>Emails>Removed 0.234 7.642 

Artifacts>OSFile>Enabled 0.306 8.192 

Artifacts>OSFile>Excluded 0.342 8.58 

Artifacts>OSFile>Removed 0.258 8.756 

http://www.exterro.com/


 

 

 

 

40 

FTK SUITE 8.2 SP2 - BENCHMARK METRICS 

© Exterro, Inc. All rights reserved.         www.exterro.com 

 

Test Scenarios 
1 User 10 Users 

Average Time taken for 1 User (In Seconds) 

Artifacts>DB>Enabled 0.344 8.47 

Artifacts>DB>Excluded 0.334 8.677 

Artifacts>DB>Removed 0.237 7.996 

Artifacts>GeoLoc>City>Load 0.144 0.482 

Artifacts>GeoLoc>City>Enable 0.7 7.917 

Artifacts>GeoLoc>City>Excluded 0.24 7.915 

Artifacts>GeoLoc>City>Removed 0.228 7.459 

Artifacts>Others>Enabled 0.261 8.257 

Artifacts>Others>Excluded 0.301 8.377 

Artifacts>Others>Removed 0.25 7.557 

Artifacts>internetBtowser>Enabled 0.426 8.448 

Artifacts>internetBtowser>Excluded 0.295 7.865 

Artifacts>internetBtowser>Removed 0.228 6.449 

Artifacts>SystemSummary>Enabled 0.727 8.892 

Artifacts>SystemSummary>Excluded 0.835 7.856 

Artifacts>SystemSummary>Removed 0.355 3.779 

 

Evidence: 

Test Scenarios 
1 User 10 Users 

Average Time to process 10 million files (In Seconds) 

Evidence 1 > Apply 5.312 2.853 

Evidence 1 > Exclude 0.198 1.942 

Evidence 1 > Remove 0.266 0.734 
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Combination Filters 1: 

Common Filters + Artifacts + Quick Filters 

 

Test Scenarios 
1 User 10 Users 

Average Time taken for 1 User (In Seconds) 

Common filter : Object types > Files and Emails 0.436 4.774 

Common filter + Artifacts >Chatapplication 0.211 4.714 

Common filter + Artifacts >Chatapplication , Documents 3.665 4.016 

Common filter + Artifacts >Chatapplication , Documents , 

Internet & Browsers 0.772 5.487 

Common filter + Artifacts >Chatapplication , Documents , 

Internet & Browsers, Emails 0.558 5.002 

Common filter + Artifacts + Quick Filter applied on>Remove 

Containers 0.787 2.396 

Common filter + Artifacts + Quick Filter applied on>Remove 

Containers, Remove Notes and Bookmark  - 

Common filter + Artifacts + Quick Filter applied on>Remove 

Containers, Remove Notes and Bookmark, Remove 

Duplicates [Combination 1 Result] [Quick Filters, Common 

Filters, Artifacts] 0.718 2.021 
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Combination Filters 1 Exclusion: 

 

Test Scenarios 
1 User 10 Users 

Average Time taken for 1 User (In Seconds) 

Combination 1 + Document from Artifact 5.078 14.626 

 

Combination Filters 2: 

Common Filters + Artifacts + Evidence 

 

Test Scenarios 
1 User 10 Users 

Average Time taken for 1 User (In Seconds) 

Common Filter>Size>Tiny 0.292 7.934 

Common Filter>Size>Tiny, Gigantic 0.245 0.841 

Common Filter>Size>Tiny, Gigantic, Small 0.24 0.747 

Common Filter>Size>Tiny, Gigantic, Small, Empty  0.341 1.065 

Common Filter + Artifacts filter> Document 0.443 5.833 

Common Filter + Artifacts filter> Document, Email 0.433 5.245 

Common Filter + Artifacts filter + Evidence Explorer>Evidence 1 0.585 2.355 

Common Filter + Artifacts filter + Evidence Explorer>Evidence 1, 

Evidence 2 0.594 2.348 

Common Filter + Artifacts filter + Evidence Explorer>Evidence 1, 

Evidence 2,Evidence 3 0.62 1.846 

Common Filter + Artifacts filter + Evidence Explorer>Evidence 1, 

Evidence 2,Evidence 3, Evidence 4 0.605 2.161 

 

  

http://www.exterro.com/


 

 

 

 

43 

FTK SUITE 8.2 SP2 - BENCHMARK METRICS 

© Exterro, Inc. All rights reserved.         www.exterro.com 

 

Combination Filters 2 Exclusion: 

 

Test Scenarios 
1 User 10 Users 

Average Time taken for 1 User (In Seconds) 

Combination 2 Filters + Common Filter>size>Small 1.103 3.323 

Combination 2 Filters + Common Filter>size>Small, Empty 1.066 3.289 

Combination 2 Filters + Evidence explorer>Evidence 1 6.196 14.512 

Combination 2 Filters + Evidence explorer>Evidence 1, 

Evidence 2 4.477 8.907 

 

Combination Filters 3:  

Evidence Dropdown + Evidence Explorer 

 

Test Scenarios 
1 User 10 Users 

Average Time taken for 1 User (In Seconds) 

Evidence dropdown>Select Evidence 1 1.822 4.129 

Evidence dropdown>Select Evidence 1, Evidence 2 1.921 4.768 

Evidence dropdown>Select Evidence 1, Evidence 2, Evidence 3 2.03 4.505 

Evidence dropdown>Select Evidence 1, Evidence 2, Evidence 3, 

Evidence 4 0.441 4.129 

Evidence dropdown>Select Evidence 1, Evidence 2, Evidence 3, 

Evidence 4, Evidence 5 0.447 1.241 

Evidence dropdown>Select Evidence 1, Evidence 2, Evidence 3, 

Evidence 4, Evidence 5, Evidence 6 0.463 1.187 

Evidence dropdown>Select Evidence 1, Evidence 2, Evidence 3, 

Evidence 4, Evidence 5, Evidence 6, Evidence 7 0.353 9.575 

Evidence dropdown>Select Evidence 1, Evidence 2, Evidence 3, 

Evidence 4, Evidence 5, Evidence 6, Evidence 7, Evidence 8 0.364 1.45 

Evidence dropdown + Evidence Explorer>Select Evidence 1 1.946 4.614 
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Test Scenarios 
1 User 10 Users 

Average Time taken for 1 User (In Seconds) 

Evidence dropdown + Evidence Explorer>Select Evidence 1, 

Evidence 2 2.182 4.895 

Evidence dropdown + Evidence Explorer>Select Evidence 1, 

Evidence 2, Evidence 3 2.165 5.029 

Evidence dropdown + Evidence Explorer>Select Evidence 1, 

Evidence 2, Evidence 3, Evidence 4 2.182 4.826 

Evidence dropdown + Evidence Explorer>Select Evidence 1, 

Evidence 2, Evidence 3, Evidence 4, Evidence 5 0.564 1.883 

 

Combination Filters 3 Exclusion 

 

Test Scenarios 
1 User 10 Users 

Average Time taken for 1 User (In Seconds) 

Evidence dropdown + Evidence Explorer>Exclude Evidence 1 0.583 1.64 

Evidence dropdown + Evidence Explorer>Exclude Evidence 1, 

Evidence 2 0.545 1.728 

Evidence dropdown + Evidence Explorer>Exclude Evidence 1, 

Evidence 2, Evidence 3 6.451 13.644 
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Combinational Filters 3 + Combination Filters 4:  

Quick Filters + Common Filters + Artifacts 

 

Test Scenarios 
1 User 10 Users 

Average Time taken for 1 User (In Seconds) 

Artifacts>Document 6.472 15.204 

Artifacts>Document, Email 6.496 15.372 

Artifacts>Document, Email, Mobile 6.407 15.426 

Artifacts + Common Filter> Size  0.742 9.986 

Artifacts + Common Filter + Quick filter>Remove Duplicates 12.224 18.282 

Artifacts + Common Filter + Quick filter>Remove Duplicates, 

Remove Containers [Combination 3 Result] [Evidence 

Dropdown, Evidence Explorer, Artifacts, Quickfilter, 

Commonfilter] 7.751 18.312 

 

Combinational Filters 3 + Combination Filters 4 Exclusion: 

 

Test Scenarios 
1 User 10 Users 

Average Time taken for 1 User (In Seconds) 

Artifacts>Document 7.665 16.531 

Evidence Explorer>Exclude Evidence 1 7.172 12.543 

Evidence Explorer>Exclude Evidence 1, Evidence 2 5.892 11.49 

Evidence Explorer>Exclude Evidence 1, Evidence 2, Evidence 3 6.141 16.209 
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List View - Column Template List 

 

Test Scenarios 
1 User 10 Users 

Average Time taken for 1 User (In Seconds) 

Column Template List > Documents - - 

Column Template List > Airdrop background activity & 

discoverability  
2.168 5.443 

Column Template List > Apple Maps 2.217 5.99 

Column Template List > Applications 2.269 7.04 

Column Template List > Bluetooth network 2.235 6.658 

Column Template List > Calendar 2.271 7.383 

Column Template List > Common 2.179 7.311 

Column Template List > Device information 2.432 7.252 

Column Template List > Email 0.255 7.465 

Column Template List > Health Data 2.158 6.974 

Column Template List > Installed App 2.368 6.903 

Column Template List > InteractionC Information 2.164 6.238 

Column Template List > Internet 2.276 6.629 

Column Template List > Keychain Information 2.183 6.629 

Column Template List > KnowledgeC Information 2.146 7.026 

Column Template List > Layout 2.331 7.779 

Column Template List > Location 2.076 7.388 

Column Template List > LocationD Information 2.363 6.98 

Column Template List > MMS 2.312 7.219 

Column Template List > Media 2.29 7.251 

Column Template List > Memory Analysis 2.156 7.149 

Column Template List > Mobile 2.342 6.79 

Column Template List > Notes 2.158 6.796 

Column Template List > Password 2.192 6.693 
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Test Scenarios 
1 User 10 Users 

Average Time taken for 1 User (In Seconds) 

Column Template List > Report 2.21 6.83 

Column Template List > RoutineD cached locations data 2.324 6.838 

Column Template List > Search 2.262 6.493 

Column Template List > Software Inventory 2.242 6.957 

Column Template List > Summary Information 2.121 7.116 

Column Template List > Timeline 0.191 7.204 

Column Template List > Volatile 2.311 6.821 

Column Template List > WebHistory 2.053 5.746 

Column Template List > Wireless Network 2.372 4.902 

 

Thumbnail View - Sort By 

 

Test Scenarios 
1 User 10 Users 

Average Time taken for 1 User (In Seconds) 

Sort by > Name (ASC) 1.296 3.551 

Sort by > Created Date (ASC) 2.316 8.642 

Sort by > Last Modified Date (ASC) 2.359 9.386 

Sort by > Path (ASC) 1.403 4.057 

Sort by > Logical Size (ASC) 5.363 11.897 

Sort by > Extension (ASC) 1.273 3.281 

Sort by > Duration (ASC) 1.324 3.833 

Sort by > Exif Image Make (ASC) 1.915 5.222 

Sort by > Exif Image Model (ASC) 1.25 4.757 

Sort by > Stacks (ASC) 17.127 8.307 

Sort by > Location City (ASC) 1.301 4.629 

Sort by > Location Country (ASC) 1.241 4.626 

Sort by > Name (DESC) 1.239 3.82 
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Test Scenarios 
1 User 10 Users 

Average Time taken for 1 User (In Seconds) 

Sort by > Created Date (DESC) 2.324 10.838 

Sort by > Last Modified Date (DESC) 2.28 8.873 

Sort by > Path (DESC) 2.963 7.146 

Sort by > Logical Size (DESC) 1.281 3.856 

Sort by > Extension (DESC) 1.369 2.834 

Sort by > Duration (DESC) 1.257 2.704 

Sort by > Exif Image Make (DESC) 1.334 4.282 

Sort by > Exif Image Model (DESC) 1.336 3.686 

Sort by > Stacks (DESC) 5.262 9.07 

Sort by > Location City (DESC) 1.275 3.726 

Sort by > Location Country (DESC) 1.315 3.733 

 

Thumbnail View - Group By: 

 

Test Scenarios 
1 User 10 Users 

Average Time taken for 1 User (In Seconds) 

Group by > Name 1.068 4.935 

Group by > Created Date 2.05 6.867 

Group by > Last Modified Date 1.938 7.484 

Group by > Duration 0.402 0.742 

Group by > Extension 0.744 2.396 

Group by > Logical Size 0.243 0.468 

Group by > Exif Image Make 1.214 3.349 

Group by > Exif Image Model 1.855 4.531 

Group by > Stacks 4.79 11.038 

Group by > Location City 1.801 2.755 

Group by > Location Country 1.791 2.695 
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Standalone Performance Comparison between FTK Central 8.2 SP1 and FTK Central 8.2 SP2 

 

The below mentioned comparison table displays the Improvement (in percentage) between FTK Central 8.2 SP1 and 

FTK Central 8.2 SP2 for a single user and 10 users in PostgreSQL database where the ramp-up period is 3 seconds: 

For 1 User: 

 

Areas 

FTKC 8.2 SP1 

(Average time in seconds) 

FTKC 8.2 SP2 

(Average time in seconds) 

1 User 

Manage Page loading 2.110 3.454 

Navigations 0.661 0.501 

Quick Filters 0.212 0.217 

Common Fitlers 0.749 1.232 

Column Filters 1.394 3.018 

Artifacts Filters 2.205 0.528 

Evidence Explorer 0.309 1.925 

Complex Searches 1.013 2.427 

Combinational Filters 1.526 2.518 

Column Template List 2.173 2.113 

Thumbnail View - Sort by 2.483 2.558 

Thumbnail View - Group by 5.494 1.627 

AVERAGE 1.694 1.843 
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For 10 Users 

 

Areas 

FTKC 8.2 SP1 

(Average time in seconds) 

FTKC 8.2 SP2 

(Average time in seconds) 

1 User 

Manage Page loading 4.927 8.088 

Navigations 2.437 1.244 

Quick Filters 1.378 0.446 

Common Fitlers 10.325 3.007 

Column Filters 18.830 4.527 

Artifacts Filters 12.242 7.837 

Evidence Explorer 0.751 1.843 

Complex Searches 4.192 3.645 

Combinational Filters 4.253 6.709 

Column Template List 12.656 6.871 

Thumbnail View - Sort by 7.549 5.698 

Thumbnail View - Group by 8.488 4.296 

AVERAGE 7.336 4.518 
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Contact Exterro 

If you have any questions, please refer to this document, or any other related materials provided to you by Exterro. 

For usage questions, please check with your organization’s internal application administrator. Alternatively, you may 

contact your Exterro Training Manager or other Exterro account contact directly. 

 

For technical difficulties, support is available through support@exterro.com. 

 

Contact:  

Exterro, Inc. 

2175 NW Raleigh St., Suite 110 

Portland, OR 97210. 

Telephone: 503-501-5100 

Toll Free: 1-877-EXTERRO (1-877-398-3776) 

Fax: 1-866-408-7310 

General E-mail:info@exterro.com 

Website: www.exterro.com 

 

 

 

 

Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, 

electronic or mechanical, for any purpose, without the express written permission of Exterro, Inc. The trademarks, service marks, logos or other intellectual 

property rights of Exterro, Inc and others used in this documentation ("Trademarks") are the property of Exterro, Inc and their respective owners. The 

furnishing of this document does not give you license to these patents, trademarks, copyrights or other intellectual property except as expressly provided in 

any written agreement from Exterro, Inc.  

The United States export control laws and regulations, including the Export Administration Regulations of the U.S. Department of Commerce, and other 

applicable laws and regulations apply to this documentation which prohibits the export or re-export of content, products, services, and technology to certain 

countries and persons. You agree to comply with all export laws, regulations and restrictions of the United States and any foreign agency or authority and 

assume sole responsibility for any such unauthorized exportation. 

You may not use this documentation if you are a competitor of Exterro, Inc, except with Exterro Inc’s prior written consent. In addition, you may not use the 

documentation for purposes of evaluating its functionality, or for any other competitive purposes.  

If you have any questions, please contact Customer Support by email at support@exterro.com. 
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