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About Exterro 

Exterro was founded with the simple vision that applying the concepts of process optimization and data science to 

how companies manage digital information and respond to litigation would drive more successful outcomes at a 

lower cost. We remain committed to this vision today. We deliver a fully integrated Data Risk Management platform 

that enables our clients to address their privacy, regulatory, compliance, digital forensics, and litigation risks more 

effectively and at lower costs. We provide software solutions that help some of the world’s largest organizations, law 

enforcement and government agencies work smarter, more efficiently, and support the Rule of Law. 

1 Processing Metrics 

The processing count and time of various evidence in FTK 8.2 SP2 HF5 version are recorded. 

 

AWS Machine Configuration: 
 

The metrics are recorded with an AWS machine with the following configuration: 

• Server Versions: Windows Server 2022 datacenter 

• Processor: Intel(R) Xeon(R) Platinum 8259 CL @ 2.50GHz 

• System Type: 64 bit 

• RAM: 128 GB 

• Instance Type: m5.8x Large (16 core processor) 

 

Distributed Processing Manager:  

• Exterro FTK application is installed in a separate AWS machine. 

• The Exterro Database is hosted in a separate AWS machine. 

• Distributed Processing Manager (DPM) is installed in a separate machine. 

• 3 Distributed Processing Engines (DPEs) are installed in 3 individual AWS machines. 
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2 Performance Benchmark Metrics 

2.1 Performance Benchmark environment and configuration 
 

A series of performance tests were executed to determine the application load time response when bulk users are 

accessing the application. A maximum of 10 users were made to log in to the application simultaneously with a ramp-

up period of 3 seconds and randomly hit all the Manage pages. 

 

The load details of the database and the server is provided below: 
 

# Name of the Entity Active Count 

1 Case 2 

2 Review Page 28,172,887 

3 Total no. of files in all the cases ~ 92 Million 

 

 

Server 
Instance 

type/processor 

Drive 
RAM Size 

Operating 

System Size Type R/W Speed 

Application 

Server  

m5.8x Large  

(16 core processor) 

3.2 TB  

(200 GB, 3 TB) 
SSD 16,000 128 GB 

Windows Server 

2022 (64 - bit OS) 

Database Server 
m5.8x Large  

(16 core processor) 

4 TB  

(500 GB, 3 TB, 

500 GB) 

SSD 16,000 128 GB 
Windows Server 

2022 (64 - bit OS) 
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2.1.1 Test Bed Set-up 

 

1. The tests were performed on the below user preference settings in the application: 

• Manage Page View : Table View 

• Results per page : 100 

• Ramp-up  : 3 seconds 

 
 

2. The performance scripts of the Manage pages were taken by triggering the APIs from an AWS machine (say 

Machine 1) and hitting the other AWS machine (say Machine 2). Here, Machine 1 consisted of the Performance 

Test scripts and Machine 2 consisted of Performance Test data. 

 

2.1.2 AWS Machine Details 

 

• Server Versions : Windows Server 2022 Datacenter (64 – bit OS) 

• RAM    : 128 GB 

• Database Server : MS SQL 

 

Important: The metrics are recorded with database cache and index implementation. The database cache query is 

executed upon every successful upgrade and new installation. 

 

Name of the Page 
No. of users - 1 No. of users - 10 

Average Time Taken (in seconds) 

Manage Case 0.26 0.60 

Review 0.71 5.90 

Thumbnail View 0.82 1.11 
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2.2 Overview of Performance Fixes 

 

1. Artifact Filters - Common Filters: 

• Implemented caching for Facet Tree and Facet List to improve overall filter performance. 

• Certain facets are excluded from caching due to frequent updates based on user activity. These include: 

o Labels 

o Bookmarks 

o Issues 

o Custodians 

o KFF 

o Language 

o Evidence Explorer 

o Viewed facet types 

• The cache is refreshed whenever the Object ID increases, such as during: 

o Job add evidence 

o Additional analysis 

o Import jobs 

 

2. Raw Call Cache: 

• Cache refresh interval is set to every 2 hours. 

• SmartGrid Cache has been implemented for raw calls used in: 

o List view 

o Thumbnail view 

• SmartGrid Cache has also been implemented for column filter APIs, which are used in SmartGrid view. 

• When UI filters include any of the non-cached facets listed above, the system falls back to the normal 

database flow for all related APIs. 
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3. Thumbnail View Performance Improvements: 

• Enhanced performance for: 

o Sort By 

o Group By 

 

4. Evidence Explorer: 

• Improved data retrieval and filtering performance. 
 

5. Manage Page: 

• Optimized page load performance through improved caching mechanisms. 
 

6. Filter Performance Enhancements: 

• Applied performance improvements across: 

o Quick Filters 

o Column Filters 

o Combinational Filters 

 

7. Column Template List: 

• Caching was already implemented for findAllAttributesByColumnSet. 

• Modified to initialize the cache during service startup. 

• Existing raw call caching is reused with no additional changes. 

 

8. Chat: 

• Chat conversation and chat conversion enhancements in the Review Screen. The viewer is now capable of 

loading larger chats faster than before. 

 

9. Reports 

• Fixed performance issues where the Reports wizard took a long time to load when a large number of 

objects were labeled or bookmarked. 

• Optimized the Report Submission API to handle large volumes of labeled or bookmarked objects more 

efficiently.  

http://www.exterro.com/


 

 

 

 

9 

FTK SUITE 8.2 SP2 HF5 - BENCHMARK METRICS 

© Exterro, Inc. All rights reserved.         www.exterro.com 

 

3 Multiuser Performance Metrics in FTK Central 8.2 SP2 HF5 

The below time stamps (in seconds) are recorded as a comparison between 1 user and 10 users with 28 million files 

in FTK Central 8.2 SP2 HF5 application (PostgreSQL database) where the ramp-up period is 3 seconds. 

 

3.1 Manage Page 

 

Scenarios 
1 User 10 Users 

Average Time Taken (In Seconds) 

Manage Case List 0.26 0.60 

Review Page 0.71 5.90 

 

 

3.2 Individual API 

 

Scenarios 
1 User 10 Users 

Average Time Taken (In Seconds) 

Not Viewed  0.00 0.00 

Artifacts API 4.18 1.37 

Evidence Explorer API 0.27 0.16 
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3.3 Quick Filters 

 

Scenarios 
1 User 10 Users 

Average Time Taken (In Seconds) 

Quick Filter > Labeled Fields > Apply 0.63 1.60 

Quick Filter > Labeled Fields > Remove 0.60 1.45 

Quick Filter > Checked Files > Apply 0.55 1.28 

Quick Filter > Checked Files > Remove 0.60 1.00 

Quick Filter > Toggle Bookmark or Reports Filter > Apply 0.64 0.90 

Quick Filter > Toggle Bookmark or Reports Filter > Remove 0.60 0.85 

Quick Filter > Ignorable > Apply 0.55 0.80 

Quick Filter > Ignorable > Remove 0.60 0.81 

Quick Filter > Internet Favorites > Apply 0.58 0.72 

Quick Filter > Internet Favorites > Remove 0.61 0.78 

Quick Filter > Privileged > Apply 0.56 0.72 

Quick Filter > Privileged > Remove 0.61 0.78 

Quick Filter > Remove Duplicates > Apply 1.84 0.98 

Quick Filter > Remove Duplicates > Remove 0.76 1.00 

Quick Filter > Deleted Files > Apply 0.72 0.78 

Quick Filter > Deleted Files > Remove 0.60 0.78 

Quick Filter > Carved Files > Apply 0.57 0.75 

Quick Filter > Carved Files > Remove 0.61 0.76 

Quick Filter > Encrypted Files > Apply 0.63 0.76 

Quick Filter > Encrypted Files > Remove 0.61 0.76 

Quick Filter > From Recycle Bin > Apply 0.82 0.80 

Quick Filter > From Recycle Bin > Remove 0.64 0.79 

Quick Filter > Ocred Files > Apply 0.56 0.70 

Quick Filter > Ocred Files > Remove 0.60 0.78 

Quick Filter > Bad Extension > Apply 0.76 0.74 
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Scenarios 
1 User 10 Users 

Average Time Taken (In Seconds) 

Quick Filter > Bad Extension > Remove 0.60 0.76 

Quick Filter > Hidden Files > Apply 0.67 0.80 

Quick Filter > Hidden Files > Remove 0.60 0.78 

Quick Filter > Email Attachment > Apply 1.20 0.84 

Quick Filter > Email Attachment > Remove 0.64 0.82 

Quick Filter > Geo Location > Apply 0.63 0.78 

Quick Filter > Geo Location > Remove 0.60 0.77 

Quick Filter > Ediscovery Refinement > Apply 3.90 1.05 

Quick Filter > Ediscovery Refinement > Remove 0.79 1.05 

Quick Filter > Containers > Apply 2.47 0.97 

Quick Filter > Containers > Remove 0.77 0.95 

 

  

http://www.exterro.com/


 

 

 

 

12 

FTK SUITE 8.2 SP2 HF5 - BENCHMARK METRICS 

© Exterro, Inc. All rights reserved.         www.exterro.com 

 

3.4 Artifacts 

 

Scenarios 
1 User 10 Users 

Average Time Taken (In Seconds) 

Artifacts > Highlight > Enabled 0.65 0.76 

Artifacts > Highlight > Excluded 1.75 1.34 

Artifacts > Highlight > Removed 1.27 0.71 

Artifacts > Multimedia > Enabled 0.72 0.96 

Artifacts > Multimedia > Excluded 1.30 2.33 

Artifacts > Multimedia > Removed 0.65 0.65 

Artifacts > Mobile > Enabled 0.85 1.02 

Artifacts > Mobile > Excluded 1.57 1.58 

Artifacts > Mobile > Removed 0.64 1.82 

Artifacts > Chat Apps > Enabled 0.73 0.87 

Artifacts > Chat Apps > Excluded 1.42 1.10 

Artifacts > Chat Apps > Removed 0.64 0.70 

Artifacts > Documents > Enabled 0.75 2.52 

Artifacts > Documents > Excluded 2.10 1.84 

Artifacts > Documents > Removed 0.64 0.69 

Artifacts > Emails > Enabled 0.27 0.96 

Artifacts > Emails > Excluded 1.25 2.41 

Artifacts > Emails > Removed 1.42 0.69 

Artifacts > OS Files > Enabled 0.63 0.91 

Artifacts > OS Files > Excluded 0.78 1.61 

Artifacts > OS Files > Removed 1.52 0.66 

Artifacts > Databases > Enabled 0.73 0.90 

Artifacts > Databases > Excluded 0.84 1.72 

Artifacts > Databases > Removed 2.09 0.69 

Artifacts > Geo Location > City > Load 1.70 0.10 
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Scenarios 
1 User 10 Users 

Average Time Taken (In Seconds) 

Artifacts > Geo Location > City > Enable 0.67 0.71 

Artifacts > Geo Location > City > Excluded 2.47 1.33 

Artifacts > Geo Location > City > Removed 1.73 0.69 

Artifacts > Others > Enabled 0.70 1.16 

Artifacts > Others > Excluded 2.98 1.52 

Artifacts > Others > Removed 1.67 0.69 

Artifacts > Internet Browser > Enabled 0.66 0.98 

Artifacts > Internet Browser > Excluded 2.25 1.57 

Artifacts > Internet Browser > Removed 1.67 0.68 

Artifacts > System Summary > Enabled 0.72 0.86 

Artifacts > System Summary > Excluded 2.62 1.12 

Artifacts > System Summary > Removed 2.03 0.69 
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3.5 Common Filter 

 

Scenarios 
1 User 10 Users 

Average Time Taken (In Seconds) 

Common Filter > Bookmarks > Load 0.77 0.19 

Common Filter > Bookmarks > Apply 0.73 0.97 

Common Filter > Bookmarks > Remove 0.63 0.94 

Common Filter > Cerebrus STG1 > Load 0.41 0.29 

Common Filter > Custodians > Load 2.22 2.20 

Common Filter > Custom Field > Load 0.24 0.09 

Common Filter > Date Accessed > Load 0.22 0.06 

Common Filter > Date Accessed > 1 > Apply 0.96 0.69 

Common Filter > Date Accessed > 1 > Remove 0.63 0.73 

Common Filter > Date Created > Load 0.22 0.06 

Common Filter > Date Created > 1 > Apply 0.83 0.76 

Common Filter > Date Created > 1 > Remove 0.60 0.70 

Common Filter > Date Modified > 1 > Load 0.23 0.07 

Common Filter > Date Modified > 1 > Apply 0.81 0.71 

Common Filter > Date Modified > 1 > Remove 0.60 0.70 

Common Filter > Document Content > Cluster Topic > Load 0.27 0.11 

Common Filter > Document Content > Cluster Topic > Apply 0.56 0.64 

Common Filter > Document Content > Email Address > Load 0.05 0.05 

Common Filter > Document Content > CCN > Load 0.05 0.05 

Common Filter > Document Content > Phone Number > Load 0.05 0.06 

Common Filter > Document Content > SSN > Load 0.05 0.06 

Common Filter > Viewed > Load 1.18 1.05 

Common Filter > Viewed > NV > Apply 0.64 0.77 

Common Filter > Viewed > NV > Remove 0.60 0.79 

Common Filter > Viewed > V > Apply 0.60 0.75 
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Scenarios 
1 User 10 Users 

Average Time Taken (In Seconds) 

Common Filter > Viewed > V > Remove 0.63 0.75 

Common Filter > Status > Load 0.22 0.07 

Common Filter > Status > Bad Extension > Apply 0.91 0.84 

Common Filter > Status > Bad Extension > Remove 0.60 0.81 

Common Filter > Status > Deleted Files > Apply 0.61 0.84 

Common Filter > Status > Deleted Files > Remove 0.59 0.87 

Common Filter > Status > Email Attachment > Apply 1.11 0.85 

Common Filter > Status > Email Attachment > Remove 0.62 0.86 

Common Filter > Status > Email Related Item > Apply 1.30 0.90 

Common Filter > Status > Email Related Item > Remove 0.60 0.95 

Common Filter > Status > Email Reply > Apply 0.91 1.00 

Common Filter > Status > Email Reply > Remove 0.60 1.00 

Common Filter > Status > Encrypted Files > Apply 0.65 0.96 

Common Filter > Status > Encrypted Files > Remove 0.71 0.93 

Common Filter > Status > Recycle Bin > Apply 0.87 1.73 

Common Filter > Status > Recycle Bin > Remove 0.61 0.82 

Common Filter > Size > Load 1.79 0.07 

Common Filter > Size > Gigantic > Apply 0.64 0.83 

Common Filter > Size > Gigantic > Remove 0.64 0.83 

Common Filter > Size > Huge > Apply 0.63 0.82 

Common Filter > Size > Huge > Remove 1.95 0.82 

Common Filter > Size > Large > Apply 0.64 0.79 

Common Filter > Size > Large > Remove 0.61 0.80 

Common Filter > Size > Medium > Apply 0.66 0.79 

Common Filter > Size > Medium > Remove 0.61 0.78 

Common Filter > Size > Small > Apply 0.74 0.79 

Common Filter > Size > Small > Remove 0.61 0.80 
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Scenarios 
1 User 10 Users 

Average Time Taken (In Seconds) 

Common Filter > Size > Tiny > Apply 1.24 0.86 

Common Filter > Size > Tiny > Remove 0.61 0.96 

Common Filter > Size > Empty > Apply 0.72 1.00 

Common Filter > Size > Empty > Remove 0.60 0.96 

Common Filter > Language > Load 0.26 0.12 

Common Filter > Object Types > Load 0.85 0.07 

Common Filter > Object Types > Files Email > Apply 1.34 0.84 

Common Filter > Object Types > Files Email > Remove 0.60 0.82 

Common Filter > Production Sets > Load 1.63 0.06 

Common Filter > Production Sets > Apply 30.14 0.84 

Common Filter > Production Sets > Remove 0.61 0.91 

Common Filter > Labels > Load 0.26 0.14 

Common Filter > Labels > 1 > Apply 0.64 0.89 

Common Filter > Labels > 1 > Remove 0.62 0.79 

Common Filter > Issues > Load 0.28 0.10 

Common Filter > KFF > KFF Vendors > Load 0.24 0.08 

Common Filter > KFF > KFF Groups > Load 0.24 0.09 

Common Filter > KFF > KFF Status > Load 0.24 0.09 

Common Filter > KFF > KFF Sets > Load 0.24 0.09 

Common Filter > Email Date > Load 0.23 0.07 

Common Filter > Email Date > Received > Apply 0.93 0.86 

Common Filter > Email Date > Received > Remove 0.61 0.78 

Common Filter > Email Date > Sent > Apply 1.21 0.91 

Common Filter > Email Date > Sent > Remove 0.61 0.77 

Common Filter > Extension > Load 0.55 0.39 

Common Filter > Extension > 1 > Apply 0.72 0.78 

Common Filter > Extension > 2 > Remove 0.61 0.73 
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3.6 Column filters 

Scenarios 
1 User 10 Users 

Average Time Taken (In Seconds) 

Column Filters > Object Name > Apply 1.06 0.13 

Column Filters > Object Name > Remove 0.67 1.02 

Column Filters > Object ID > Apply 1.21 0.12 

Column Filters > Object ID > Remove 0.67 0.93 

Column Filters > Create Date > Load 0.94 0.98 

Column Filters > Create Date > Apply 0.77 0.11 

Column Filters > Create Date > Remove 0.69 0.85 

Column Filters > Last Modified Date > Load 1.14 1.19 

Column Filters > Last Modified Date > Apply 0.66 0.11 

Column Filters > Last Modified Date > Remove 0.65 0.80 

Column Filters > File Type > Load 0.30 0.12 

Column Filters > File Type > 1 > Apply 0.65 0.10 

Column Filters > File Type > Remove 0.66 0.80 

Column Filters > File Extension > Load 0.81 0.84 

Column Filters > File Extension > Apply 1.00 0.09 

Column Filters > File Extension > Remove 0.67 0.76 

Column Filters > Path > Apply 79.04 0.10 

Column Filters > Path > Remove 0.67 1.09 

Common Filter > MD5 > Apply 0.66 0.77 

Common Filter > MD5 > Remove 0.67 1.12 

3.7 Evidences 

Scenarios 
1 User 10 Users 

Average Time Taken (In Seconds) 

Evidence 1 > Apply 1.35 1.69 

Evidence 1 > Exclude 1.00 0.93 

Evidence 1 > Remove 0.60 0.86 
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3.8 List View 

3.8.1 Combination Filters 1: Common Filters + Artifacts + Quick Filters 

 

Scenarios 

1 User 10 Users 

Average Time Taken (In 

Seconds) 

Common Filter > Object Types > Files and Emails 1.41 1.92 

Common Filter + Artifacts > Chat Applications 0.79 2.62 

Common Filter + Artifacts > Chat Applications, Documents 0.84 3.02 

Common Filter + Artifacts > Chat Applications, Documents, Internet & Browsers 0.93 3.28 

Common Filter + Artifacts > Chat Applications, Documents, Internet & Browsers, 

Emails 
1.01 3.92 

Common Filter + Artifacts + Quick Filter Applied On > Remove Containers 1.02 3.47 

Common Filter + Artifacts + Quick Filter Applied On > Remove Containers, 

Remove Notes and Bookmarks, Remove Duplicates [Combination 1 Result] 

[Quick Filters, Common Filters, Artifacts] 

1.27 4.44 
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3.8.2 Combination Filters 2: Common Filters + Artifacts + Evidence 

 

Scenarios 

1 User 10 Users 

Average Time Taken (In 

Seconds) 

Common Filter > Size > Tiny 0.58 1.72 

Common Filter > Size > Tiny, Gigantic 0.70 1.89 

Common Filter > Size > Tiny, Gigantic, Small 0.62 1.85 

Common Filter > Size > Tiny, Gigantic, Small, Empty 0.62 1.69 

Common Filter + Artifacts Filter > Document 0.73 2.75 

Common Filter + Artifacts Filter > Document, Email 0.74 2.66 

Common Filter + Artifacts Filter + Evidence Explorer > Armstrong 0.82 19.78 

Common Filter + Artifacts Filter + Evidence Explorer > Armstrong, Narcos_001 0.85 9.61 

Common Filter + Artifacts Filter + Evidence Explorer > Armstrong, Narcos_001, 

Enron_PST 
0.83 2.80 

Common Filter + Artifacts Filter + Evidence Explorer > Armstrong, Narcos_001, 

Enron_PST, MiDatavol.ad1 [Combination 2 Result] [Common, Artifacts, 

Evidence] 

0.82 3.26 

 

 

3.8.3 Combination Filters 1 Exclusion: 

 

Scenarios 
1 User 10 Users 

Average Time Taken (In Seconds) 

Combination 1 + Document from Artifact 1.19 3.48 
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3.8.4 Combination Filters 2 Exclusion: 

 

Scenarios 

1 User 10 Users 

Average Time Taken (In 

Seconds) 

Combination 2 Filters + Common Filter > Size > Small 0.83 2.92 

Combination 2 Filters + Common Filter > Size > Small, Empty 0.81 3.10 

Combination 2 Filters + Evidence Explorer > Armstrong 0.87 3.14 

Combination 2 Filters + Evidence Explorer > Armstrong, Narcos_001 [Exclusion 

Combo 2 Result] 
0.81 3.49 

 

 

3.8.5 Combination Filters 3: Evidence Dropdown + Evidence Explorer 

 

Scenarios 

1 User 10 Users 

Average Time Taken (In 

Seconds) 

Evidence Dropdown > Conspiracy 1.04 2.24 

Evidence Dropdown > Conspiracy, Enron PST 1.04 3.06 

Evidence Dropdown > Conspiracy, Enron PST, MacMini 1.04 2.70 

Evidence Dropdown > Conspiracy, Enron PST, MacMini, Mantooth 1.04 3.10 

Evidence Dropdown > Conspiracy, Enron PST, MacMini, Mantooth, Sheriff Taylor 1.07 3.15 

Evidence Dropdown > Conspiracy, Enron PST, MacMini, Mantooth, Sheriff Taylor, 

Armstrong 
1.05 3.13 

Evidence Dropdown > Conspiracy, Enron PST, MacMini, Mantooth, Sheriff Taylor, 

Armstrong, Lenovo A369i 
1.05 3.12 

Evidence Dropdown > Conspiracy, Enron PST, MacMini, Mantooth, Sheriff Taylor, 

Armstrong, Narcos_001, MiDataVol.ad1 
1.05 3.05 

Evidence Dropdown + Evidence Explorer > Conspiracy 1.52 4.47 
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Scenarios 

1 User 10 Users 

Average Time Taken (In 

Seconds) 

Evidence Dropdown + Evidence Explorer > Conspiracy, Enron PST 1.52 4.63 

Evidence Dropdown + Evidence Explorer > Conspiracy, Enron PST, M1DataVol 1.53 4.53 

Evidence Dropdown + Evidence Explorer > Conspiracy, Enron PST, M1DataVol, 

MacMini 
1.50 4.45 

Evidence Dropdown + Evidence Explorer > Conspiracy, Enron PST, M1DataVol, 

MacMini, Mantooth [Combination 3 Result] [Evidence Dropdown, Evidence 

Explorer] 

1.49 4.43 

 

 

3.8.6 Combination Filters 3 Exclusion: 

 

Scenarios 

1 User 10 Users 

Average Time Taken (In 

Seconds) 

Evidence Explorer > Conspiracy 1.52 4.27 

Evidence Explorer > Conspiracy, M1DataVol 1.50 4.31 

Evidence Explorer > Conspiracy, M1DataVol, Mantooth [Exclusion Combo 3 

Result] 
1.51 4.25 
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3.8.7 Combination Filters 4: Evidence Dropdown + Evidence Explorer + Artifacts + Quick Filter + Common Filter 

 

Scenarios 

1 User 10 Users 

Average Time Taken (In 

Seconds) 

Artifacts > Document 1.36 4.64 

Artifacts > Document, Email 1.37 4.98 

Artifacts > Document, Email, Mobile 1.79 5.27 

Artifacts + Common Filter > Size 1.75 5.71 

Artifacts + Common Filter + Quick Filter > Remove Duplicates 1.78 5.21 

Artifacts + Common Filter + Quick Filter > Remove Duplicates, Remove Containers 

[Combination 3 Result] [Evidence Dropdown, Evidence Explorer, Artifacts, Quick 

Filter, Common Filter] 

1.77 5.46 
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3.8.8 Combination Filters 4 Exclusion 

 

Scenarios 
1 User 10 Users 

Average Time Taken (In Seconds) 

Artifacts > Document 1.72 4.83 

Evidence Explorer > MacMini 1.69 5.12 

Evidence Explorer > MacMini, MiDataVol 1.70 4.52 

Evidence Explorer > MacMini, MiDataVol, Conspiracy [Exclusion Combo 4 

Result] 
1.23 3.65 

Column Template List > Airdrop Background Activity & Discoverability 0.65 0.99 

Column Template List > Apple Maps 0.64 0.93 

Column Template List > Applications 0.64 0.90 

Column Template List > Bluetooth Network 0.64 0.91 

Column Template List > Calendar 0.65 0.90 

Column Template List > Common 0.65 0.85 

Column Template List > Device Information 0.76 0.92 

Column Template List > Email 0.66 0.90 

Column Template List > Health Data 0.63 0.90 

Column Template List > Installed App 0.68 0.91 

Column Template List > InteractionC Information 0.65 0.91 

Column Template List > Internet 0.65 0.90 

Column Template List > Keychain Information 0.64 0.91 

Column Template List > KnowledgeC Information 0.65 0.92 

Column Template List > Layout 0.70 0.91 

Column Template List > Location 0.61 0.85 

Column Template List > LocationD Information 0.64 0.91 

Column Template List > MMS 0.66 0.92 

Column Template List > Media 0.64 0.90 

Column Template List > Memory Analysis 0.64 0.91 
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Scenarios 
1 User 10 Users 

Average Time Taken (In Seconds) 

Column Template List > Mobile 0.65 0.90 

Column Template List > Others 0.66 0.91 

Column Template List > Notes 0.63 0.91 

Column Template List > Password 0.67 0.91 

Column Template List > Report 0.65 0.90 

Column Template List > RoutineD Cached Locations Data 0.70 0.92 

Column Template List > Search 0.65 0.90 

Column Template List > Software Inventory 0.65 0.89 

Column Template List > Summary Information 0.64 0.86 

Column Template List > Timeline 0.65 0.84 

Column Template List > Volatile 0.66 0.83 

Column Template List > WebHistory 0.67 0.82 

Column Template List > Wireless Network 0.66 0.78 
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3.9 Thumbnail View 

 

3.9.1 Manage Page 

 

Scenarios 
1 User 10 Users 

Average Time Taken (In Seconds) 

Manage Thumbnail View 0.82 1.11 

 

3.9.2 Sort By ASC 

 

Scenarios 
1 User 10 Users 

Average Time Taken (In Seconds) 

Sort by > Name (ASC) 1.05 1.06 

Sort by > Created Date (ASC) 0.60 0.94 

Sort by > Last Modified Date (ASC) 0.60 0.90 

Sort by > Path (ASC) 0.59 0.88 

Sort by > Logical Size (ASC) 0.60 0.84 

Sort by > Extension (ASC) 0.59 0.82 

Sort by > Duration (ASC) 0.59 0.80 

Sort by > Exif Image Make (ASC) 0.59 0.82 

Sort by > Exif Image Model (ASC) 0.59 0.82 

Sort by > Stacks (ASC) 43.22 0.12 

Sort by > Location City (ASC) 0.58 0.81 

Sort by > Location Country (ASC) 0.59 0.81 
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3.9.3 Sort By DESC 

 

Scenarios 
1 User 10 Users 

Average Time Taken (In Seconds) 

Sort by > Name (DESC) 0.60 0.82 

Sort by > Created Date (DESC) 0.59 0.81 

Sort by > Last Modified Date (DESC) 0.59 0.81 

Sort by > Path (DESC) 0.60 0.81 

Sort by > Logical Size (DESC) 0.60 0.82 

Sort by > Extension (DESC) 0.60 0.81 

Sort by > Duration (DESC) 0.58 0.86 

Sort by > Exif Image Make (DESC) 0.58 0.96 

Sort by > Exif Image Model (DESC) 0.58 1.23 

Sort by > Stacks (DESC) 0.18 0.12 

Sort by > Location City (DESC) 0.58 1.39 

Sort by > Location Country (DESC) 0.60 1.63 
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3.9.4 Group By 

 

Scenarios 
1 User 10 Users 

Average Time Taken (In Seconds) 

Group by > Name 66.93 10.47 

Group by > Created Date 8.31 2.71 

Group by > Last Modified Date 4.06 3.55 

Group by > Duration 1.49 1.88 

Group by > Extension 0.79 2.13 

Group by > Logical Size 9.33 2.98 

Group by > Exif Image Make 0.85 1.49 

Group by > Exif Image Model 0.83 1.75 

Group by > Stacks 1.26 3.42 

Group by > Location City 0.73 1.34 

Group by > Location Country 0.71 1.46 

 

 

3.9.5 Pagination 

 

Scenarios 
1 User 10 Users 

Average Time Taken (In Seconds) 

Next Page (100 entries) 0.64 1.18 

Previous Page (100 entries) 0.60 1.13 

Jump to any Page (100 entries) 3.59 2.99 
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3.10 Performance Comparison between FTK Central 8.2 SP2 HF4 and FTK Central 8.2 SP2 HF5 
 

The below mentioned comparison table displays the Improvement (in percentage) between FTK Central 8.2 SP2 HF4 

and FTK Central 8.2 SP2 HF5 for a single user and 10 users in PostgreSQL database where the ramp-up period is 3 

seconds: 

3.10.1 For 1 User: 

 

Areas 

FTKC 8.2 SP2 HF4 

(Average time in seconds) 

FTKC 8.2 SP2 HF5 

(Average time in seconds) 

1 User 

Manage Page loading 32.75 1.04 

Quick Filters 0.52 0.78 

Artifacts Filters 2.95 1.27 

Common Fitlers 4.53 1.04 

Column Filters 27.00 4.68 

Evidence Explorer 76.01 0.99 

Combinational Filters 53.09 1.16 

Column Template List 0.69 0.66 

Thumbnail View - Sort by 28.24 2.37 

Thumbnail View - Group by 80.53 8.66 

AVERAGE 30.63 2.26 
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3.10.2 For 10 Users 

 

 

Areas 

FTKC 8.2 SP2 HF4 

(Average time in seconds) 

FTKC 8.2 SP2 HF5 

(Average time in seconds) 

1 User 

Manage Page loading 40.21 1.52 

Quick Filters 1.34 0.87 

Artifacts Filters 3.76 1.12 

Common Fitlers 6.02 0.64 

Column Filters 86.80 0.60 

Evidence Explorer 38.00 1.16 

Combinational Filters 123.07 4.06 

Column Template List 7.67 0.89 

Thumbnail View - Sort by 120.93 0.86 

Thumbnail View - Group by 124.56 3.02 

AVERAGE 55.23 1.48 
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Contact Exterro 

If you have any questions, please refer to this document, or any other related materials provided to you by Exterro. 

For usage questions, please check with your organization’s internal application administrator. Alternatively, you may 

contact your Exterro Training Manager or other Exterro account contact directly. 

 

For technical difficulties, support is available through support@exterro.com. 

 

Contact:  

Exterro, Inc. 

2175 NW Raleigh St., Suite 110 

Portland, OR 97210. 

Telephone: 503-501-5100 

Toll Free: 1-877-EXTERRO (1-877-398-3776) 

Fax: 1-866-408-7310 

General E-mail:info@exterro.com 

Website: www.exterro.com 

 

 

 

Information in this document is subject to change without notice. No part of this document may be reproduced or transmitted in any form or by any means, 

electronic or mechanical, for any purpose, without the express written permission of Exterro, Inc. The trademarks, service marks, logos or other intellectual 

property rights of Exterro, Inc and others used in this documentation ("Trademarks") are the property of Exterro, Inc and their respective owners. The 

furnishing of this document does not give you license to these patents, trademarks, copyrights or other intellectual property except as expressly provided in 

any written agreement from Exterro, Inc.  

The United States export control laws and regulations, including the Export Administration Regulations of the U.S. Department of Commerce, and other 

applicable laws and regulations apply to this documentation which prohibits the export or re-export of content, products, services, and technology to certain 

countries and persons. You agree to comply with all export laws, regulations and restrictions of the United States and any foreign agency or authority and 

assume sole responsibility for any such unauthorized exportation. 

You may not use this documentation if you are a competitor of Exterro, Inc, except with Exterro Inc’s prior written consent. In addition, you may not use the 

documentation for purposes of evaluating its functionality, or for any other competitive purposes.  

If you have any questions, please contact Customer Support by email at support@exterro.com. 

http://www.exterro.com/
mailto:support@exterro.com
mailto:info@exterro.com
http://www.exterro.com/
mailto:support@exterro.com
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